Cloudflare Workers Outage - Hard Down
Incident Report for Edgemesh Corporation
Resolved
This incident is resolved. A full Root Cause Analysis will be made available over the next 24 hours.
Posted Oct 14, 2022 - 04:51 UTC
Monitoring
The patch has been rolled out globally
Posted Oct 14, 2022 - 04:35 UTC
Update
The root cause has been identified, the patch has been tested and confirmed and the update is rolling out fleet wide over the next 15 minutes.

The root cause was a bug in the Cloudflare Workers route bindings which disconnected Edgemesh code running at Cloudflare compute to the customer hostname (e.g. mapping yourstore.com > Edgemesh code). A full root cause will be made available at a later time.
Posted Oct 14, 2022 - 04:32 UTC
Identified
At approximately 9:04PM PST we were alerted to an issue with the Edgemesh Workers code operating on the Cloudflare network.
Edgemesh engineers are actively investigating and will provide and update at 9:30PM PST.
Posted Oct 14, 2022 - 04:14 UTC